User Tag List

Results 1 to 4 of 4

Thread: Ti-10 First Gen

  1. #1
    Regular Member
    Join Date
    Mar 2011
    Location
    Montreal, Canada
    Posts
    951
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)

    Default Ti-10 First Gen

    Hey all!

    Could you guys help me with this one. Its a used Ti-10 that is for sale.

    Many weird things with it, so I think I know the answer, however I have no experience with older rackets.
    Attached Images Attached Images                    

  2. #2
    Administrator kwun's Avatar
    Join Date
    Apr 2002
    Location
    Santa Clara, California, United States
    Posts
    36,130
    Mentioned
    55 Post(s)
    Tagged
    2 Thread(s)

    Default

    fake. the fonts are all wrong.

  3. #3
    Regular Member
    Join Date
    Mar 2011
    Location
    Montreal, Canada
    Posts
    951
    Mentioned
    19 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks for the reply!

    I didn't look much at the font, but the code on the butt cap saying SP, the SP on the shaft and the actual cone code being CH is really weird.

    I have no idea how codes were back then, but...

  4. #4
    Regular Member
    Join Date
    Dec 2012
    Location
    Vancouver
    Posts
    130
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Are those cracks??? I would think twice ...

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •