Thanks for visiting us!

Badminton Central is a free community for fans of badminton! If you find anything useful here please consider registering to see more content and get involved with our great community users, it takes less than 15 seconds! Everybody is welcome here.

Click here for a FREE account!

Lack of grip at very front (toe) of Yonex SHB100

Discussion in 'Clothing & Footwear' started by mhigham, Dec 16, 2008.

  1. mhigham

    mhigham Regular Member

    Joined:
    Oct 23, 2008
    Messages:
    95
    Likes Received:
    0
    Occupation:
    Analyst (Bank)
    Location:
    Edinburgh, UK
    I tried my new pair of these out this evening having previously used a pair of Asics. On a positive note I find them fantastically supportive, very comfortable and very light. A downside for me, and something I'm looking for some feedback on, is that twice tonight when using the toe of the shoe for grip it wasn't there and I slipped (second time I landed quite uncomfortably and painfully).

    I was playing on a varnished wooden floor which has never given me any grip problems before. With the Asics I would have certainly expected the shoes to hold and not slip. After I slipped the first time I reasoned it was due to the shoes being new, so I took them off and rubbed down the fronts on a wall exposing the rougher rubber underneath, but as mentioned above this didn't work.

    Has anyone had a similar experience, or would anyone have any suggestions? I'd really like to have confidence in the shoes as I've seen the damage awkward twists/slips etc. can do.

    Cheers

    Mark
     

Share This Page